Proyectos y Diseños RetroA500/A2000 Multi-Kickstart

Apartado dedicado a proyectos y diseños hardware del mundillo Retro que no se incluyen en los apartados anteriores.
Califica este tema
Responder
Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#81 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 17:32

De todas formas esta noche intentaré sacar uno de mis A500 (bueno, el mio...el otro es de mi hermano) y probaré a ver que pasa....

¿Con el 68010 te funciona, no?

¿Hay algún tipo de parche para el 68k o el kickstart 3.1 tiene soprte nativo para tal?


< Sistema preparado >

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#82 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 17:34

La 3.1 arranca y me sale la pantalla de 3.1 40.63 .... la imagen del floppy esperando disco .... vamos, que parece que todo bien ... pero en cuanto meto el disco del WB o cualquier otro hace intento de cargarlo y adiós .... pantalla negra ... No entiendo nada, la verdad ....

Evidentemente y ya por probar de todo, hasta con distintas disqueteras he hecho la prueba ....


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#83 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 17:35

Bone escribió:
31 Oct 2019 17:32
De todas formas esta noche intentaré sacar uno de mis A500 (bueno, el mio...el otro es de mi hermano) y probaré a ver que pasa....

¿Con el 68010 te funciona, no?

¿Hay algún tipo de parche para el 68k o el kickstart 3.1 tiene soprte nativo para tal?
Con el 68010 funciona sólo con los cerámicos, con los de plástico pasa lo mismo .... :loco4::loco3::loco2:

Si le meto a ambas placas un KS 3.1 original con 68000 o 68010 de plástico, ambas placas (la 6A y la 8) funcionan de PM ....


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#84 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 17:40

Además, buscando por la red he visto diseños que, salvo por la forma de la PCB, son idénticos (hasta por eBay los venden) y comentan que funciona sin problemas.


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#85 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 18:01

merlinkv escribió:
31 Oct 2019 17:40
Además, buscando por la red he visto diseños que, salvo por la forma de la PCB, son idénticos (hasta por eBay los venden) y comentan que funciona sin problemas.
¿Podrias medir el voltaje en el pin14 o pin44 del 68000? En teoria han de ser 5v, pero seguro que no lo son. La cifra suele ser 4.80v-4.95v por la caida de tensión.
Midelo en todos los 68k, please...
Me pillas en el curro y no puedo probar nada. Sigo pensando que el 68010 cerámico tiene el umbral de sus niveles algo diferentes al encapsulado plástico.
¿tienes algun 68hc000, o sea CMOS? para ver si chuta o que...


< Sistema preparado >

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#86 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 19:23

Ponga los 68000 o 68010 ... siempre lo mismo: 4.78v


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#87 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 19:35

4.78v es un pelín bajo...
Estoy pensando que si quieres probar, bajas las Rs a 200 Ohm (25mA) por descartar...
¿Usas la misma fuente para los tests?
¿Has probado con el A2000 con un 68k?ç
¿Tienes algún 68k CMOS?

Es por ir descartando...


< Sistema preparado >

Avatar de Usuario
pintza
Administrador
Administrador
Mensajes: 485
Registrado: 17 Nov 2018 22:42
Ubicación: Vitoria
    Windows 10 Chrome
Ha agradecido: 55 veces
Agradecido: 86 veces

#88 Re: A500/A2000 Multi-Kickstart

Mensaje por pintza » 31 Oct 2019 20:09

Yo tengo dos selectores de Rom que compré hace algunos años en AmiBay. Funcionan bien pero por ejemplo no me funciona la nueva Rom 3.1.4 con ellos. También llevan algo de electrónica por lo que la cosa quizá no sea tan sencilla, que una cosa es la teoría y otra muy distinta la práctica.

Lo de los micros es muy raro, en un clon de Spectrum que soldé hace algún tiempo existía un problemilla con el procesador. Según la técnología usada en su fabricación funcionaba o no.
Con los Motorola puede pasar algo parecido, mirando un poco por la web parece que se usaron dos tecnologías: CMOS y HMOS.

Más información aquí

Dicho esto:
Hay que descartar cosas.
Lo primero que haría yo es quitar el Multi KS y ver si funcionan diferentes configuraciones de Roms y CPUs.
Si todo funciona correctamente me centraría en el adaptador.



Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#89 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 20:34

Otra cosa que se me ocurre....

Quita R1 y R2. Deriva a tierra A18 y A19. Con esto seleccionamos el último banco, o sea, la kick 3.1.

Si funciona bien hablamos....


< Sistema preparado >

Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#90 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 20:37

pintza escribió:
31 Oct 2019 20:09
Yo tengo dos selectores de Rom que compré hace algunos años en AmiBay. Funcionan bien pero por ejemplo no me funciona la nueva Rom 3.1.4 con ellos. También llevan algo de electrónica por lo que la cosa quizá no sea tan sencilla, que una cosa es la teoría y otra muy distinta la práctica.

Lo de los micros es muy raro, en un clon de Spectrum que soldé hace algún tiempo existía un problemilla con el procesador. Según la técnología usada en su fabricación funcionaba o no.
Con los Motorola puede pasar algo parecido, mirando un poco por la web parece que se usaron dos tecnologías: CMOS y HMOS.

Más información aquí

Dicho esto:
Hay que descartar cosas.
Lo primero que haría yo es quitar el Multi KS y ver si funcionan diferentes configuraciones de Roms y CPUs.
Si todo funciona correctamente me centraría en el adaptador.
Sí...los más comunes son los H. Los HC son más raros de ver en un Amiga. Creo que un 68HC000 deberia funcionar como el cerámico, pero eso es matar moscas a cañonazos...es solo por descartar. Creo que el asunto viene por los niveles 0-1, que no son del todo "legales".


< Sistema preparado >

Avatar de Usuario
droman
Amiga 1200
Amiga 1200
Mensajes: 319
Registrado: 28 Jun 2019 09:25
Ubicación: En algún lugar cerca de Null
    Windows 10 Chrome
Ha agradecido: 47 veces
Agradecido: 47 veces
Contactar:

#91 Re: A500/A2000 Multi-Kickstart

Mensaje por droman » 31 Oct 2019 20:59

Bone escribió:
31 Oct 2019 15:00
1- Si el 68010 cerámico se diferéncia en algo más que el encapsulado y su die esta fabricado con materiales de mejor calidad, puede resultar más tolerante a "ceros débiles" o "unos fuertes". O sea, yo probaria a bajar la impedancia de R1 y R2 a 2k2 o 1K, ya que tener ese cero (5v a 0,5mA) débil puede provocar algún comportamiento variante en los umbrales.

Joé.... pues lo que yo decía.... que pin a pin y pum a pum... solo que Bone ha entrado en detalles. Os lo ha dejado mascao... así no aprendéis ná....


Sega Megadrive - Amstrad CPC 464 - Amstrad CPC 6128 - Spectrum +2 - Spectrum +3 - Amiga 1200 - MSX2 - Raspberry PI - Raspberry PI 2b, Raspberry PI 3+, PC... muchos PC...

Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#92 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 21:02

:sarcastico1::sarcastico1::sarcastico1::sarcastico1:


< Sistema preparado >

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#93 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 21:12

Uffffff ya me sale humo de LA neurona .... :sarcastico1::sarcastico1::sarcastico1:

Bueno he probado con otras dos fuentes que me dan 4.83-4.85v y he puesto resistencias de 4K7.

Lo mismo, la única ROM que no funciona es la 3.1

En mis A500 6a y A2000 6.2 pasa lo mismo, funcionan de PM solo con los 68010 cerámicos ...

Con las ROMs 1.2, 1.3, 2.05 y 3.1 originales las placas base funcionan de PM con todos los procesadores y las tres PSU's ...


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#94 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 21:17

merlinkv escribió:
31 Oct 2019 21:12
Uffffff ya me sale humo de LA neurona .... :sarcastico1::sarcastico1::sarcastico1:

Bueno he probado con otras dos fuentes que me dan 4.83-4.85v y he puesto resistencias de 4K7.

Lo mismo, la única ROM que no funciona es la 3.1

En mis A500 6a y A2000 6.2 pasa lo mismo, funcionan de PM solo con los 68010 cerámicos ...

Con las ROMs 1.2, 1.3, 2.05 y 3.1 originales las placas base funcionan de PM con todos los procesadores y las tres PSU's ...
Prueba lo del msg #89 :colgado1:


< Sistema preparado >

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#95 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 21:51

Hola a todos .... joder ... no os lo vais a creer .... no era problema del adaptador ... es que tenía mal compilada la 3.1 y tenía dentro un módulo que añadí en su día para el A500 y A2000 de trabajo y que fuese compatible con el mogollón de modificaciones que tienen en la placa base.

He compilado la 3.1 original y ..... voilá .... funcionan las 4 ROMs ....

Eso sí, he encontrado que mejor usar resistencias de 4K7 y no las de 10K.

Lo de reducir la impedancia del circuito ha sido una muy buena idea.


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 10 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#96 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 21:53

Entonces....¿la 3.1 anterior funcionaba bien en el 68010 ceramico? :loco1:


< Sistema preparado >

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#97 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 22:09

Pues sí, con los 68010 cerámicos funcionaba la 3.1 compilada con el módulo "alterado" y con los de plástico no.

Ahora con la 3.1 compilada original, funciona con todos los 68000 y 68010 ... un poco raro, pero es así ....

El módulo en cuestión es el gameport_keyboard_40.1 que sustituye al input_40.1 pero de qué forma afecta a solo a los de plástico, pues no lo sé la verdad ... es algo que metí hace muchos años y no lo había vuelto a tocar ...


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#98 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 22:49

Ni os imagináis que alegrón ... ya me estaba volviendo majara .... :loco4::loco4:

Bone, te debo unas cervezas.

:gracias1::gracias1:


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Avatar de Usuario
Bone
VIP
VIP
Mensajes: 787
Registrado: 26 Nov 2018 14:56
Ubicación: Mareny de Barraquetes
    Windows 7 Firefox
Ha agradecido: 55 veces
Agradecido: 90 veces

#99 Re: A500/A2000 Multi-Kickstart

Mensaje por Bone » 31 Oct 2019 23:16

merlinkv escribió:
31 Oct 2019 22:49
Ni os imagináis que alegrón ... ya me estaba volviendo majara .... :loco4::loco4:

Bone, te debo unas cervezas.

:gracias1::gracias1:
Vale...te descuento 2 de las 20 que te debo yo!! :sarcastico1::sarcastico1::sarcastico1:


< Sistema preparado >

Avatar de Usuario
merlinkv
Administrador
Administrador
Mensajes: 1362
Registrado: 17 Nov 2018 18:38
Ubicación: España / Europa del Este
    Windows 10 Firefox
Ha agradecido: 102 veces
Agradecido: 190 veces
Contactar:

#100 Re: A500/A2000 Multi-Kickstart

Mensaje por merlinkv » 31 Oct 2019 23:49

:birra1::beber1::birra1:


No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918

Califica este tema
Responder

Últimos 25 Usuarios que han visitado este Tema

merlinkv, capitan, pintza, Pingui, droman, Bone, jorsus, Valfac, tun40, Spirax, ManuelST, piccolo666

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot] y 0 invitados